foremanguy92_,

You have 3 solutions :

  • RUN THESE COMMANDS

sudo apt update && sudo apt install -y wget gnupg lsb-release apt-transport-https ca-certificates

distro=$(if echo " una bookworm vanessa focal jammy bullseye vera uma " | grep -q " $(lsb_release -sc) "; then lsb_release -sc; else echo focal; fi)

wget -O- deb.librewolf.net/keyring.gpg | sudo gpg --dearmor -o /usr/share/keyrings/librewolf.gpg

sudo tee /etc/apt/sources.list.d/librewolf.sources << EOF > /dev/null Types: deb URIs: deb.librewolf.netSuites: $distro Components: main Architectures: amd64 Signed-By: /usr/share/keyrings/librewolf.gpg EOF

sudo apt update

sudo apt install librewolf -y

  • USE THE DISTRO APP STORE
  • USE FLATPAK (just enter this command into the terminal)

flatpak install flathub io.gitlab.librewolf-communitym

possiblylinux127,

Step 1:

Go to software

Step 2: search librewolf

Step 3: install it

Sometimes the CLI is more complicated

ShitOnABrick, (edited )
@ShitOnABrick@lemmy.world avatar

Sudo apt install librewolf

Sudo apt install flatpak

Flatpak install librewolf

If that doesn’t work then I recommend you try just installing it from your package manager of choice

But if that doesn’t work then I don’t know what else I can do for you mate. Firefox broke on my version of Linux mint just uninstalled it and used unchromeium Linux and it’s subsequent distros can be quite weird at times

boredsquirrel,

You would need to add the flathub repo. But thats already done by default on Mint.

possiblylinux127,

It is only available as a flatpak

Steamymoomilk,

Or from source

possiblylinux127,

That’s a pain

Asudox, (edited )
@Asudox@lemmy.world avatar

Librewolf seems great but imo don’t use it. It’s just pre-configured stock firefox for privacy. The exact same thing can be made possible with arkenfox’s user.js. I fail to see a reason to use it just for some changed settings.

OhYeah,

That’s exactly the reason I use it. I like firefox but wish it was more secure/private out of the box which is exactly what librewolf is. Saves me time

zarkanian,
@zarkanian@sh.itjust.works avatar

Doing things the hard way doesn’t make you smarter.

wwwgem,
@wwwgem@lemmy.ml avatar

LibreWolf is indeed based on the hardened Firefox arkenfox user.js so you get its benefits which means a privacy-focused browser but Librewolf also comes with more settings pre-adjusted, telemetry removed, useless features removed…

I’ve played with Firefox settings for years before Librewolf was created and it saves me so much time, ensure my browser stays up to date and functional, and is able to perform fingerprints test way better than any other many web browsers I’ve tried.

Andromxda,

Just use the Flatpak, it makes everything much easier:
flathub.org/apps/io.gitlab.librewolf-community

smileyhead,

One thing that could help is showing what is going wrong. Do just the icon does not appear? Do some error show up?

But regardless, I see that Librewolf is not packaged in Debian official software repositories (online storage a software packages are downloaded from), so they ask you to add their own repository manually, which for APT case (package manager in Linux Mint) is an overwhelming amount of code to type to say at least.

You say you are a new user, so I can highly recommend that if something is not officially available through simple apt install to try Flatpak. Official guide: flathub.org/setup/Debian, TLDR:


<span style="color:#323232;">sudo apt install flatpak   # Installs flatpak to your system
</span><span style="color:#323232;">flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo   # Adds Flathub, the biggest store for flatpaks
</span>

Once it’s there:


<span style="color:#323232;">flatpak install librewolf
</span>

Someone using Linux for years might know where stuff on system is placed and not fear not knowing what a command do and how to undo it. But if you don’t know what is happening, better to stick to distribution provided sources. Otherwise the equivalent would be like typing some commands in Windows to change registry keys :). I think Librewolf should recommend Flatpak by default instead.

Sorry if this is too much info, just tried to explain things a little more than usual.

blakeus12,
@blakeus12@hexbear.net avatar

linux mint comes with flatpak

Pacrat173,

I believe I’ve solved the issue thank you all for the help!

jlow,

If you have the time please tell us how you solved it, it might be helpful for other people in the future with the same problem.

Pacrat173,

Changed methods I used the software manager instead

Mambert,

Websites can be vague, or outdated. Is there any error from running the command?

schwim, (edited )

As a brand new user, you don’t need to use any commands to install librewolf. Open “Software Manager”, type “libre” in the search bar and install the first result.

https://lemm.ee/pictrs/image/bd8933ac-cfd6-47a8-9e0e-a3aae7a96fce.webp

Pacrat173,

I tried that but it seems to get stuck on the loading screen saying Generating cache, one moment please I’m not sure if it’s just slow or if something is wrong

Pacrat173,

I take that back I don’t know what I done to fix it but it’s working now

nickwitha_k,

It may be worth checking to ensure that your repo mirrors are set to the best ones for your location. This can be done via the update manager.

boredsquirrel,

You either added their apt repo and installed it via apt, or you installed the Flatpak

schwim,

Sometimes, the repos(machines where the software is stored) has a hiccup that causes installs to stall and fail. When that happens, I usually give it another try in an hour or so before bothering to troubleshoot. It pretty much always resolves itself when this happens.

BaalInvoker,

Install it from your Software Center. It’s really easy and need no command at all.

Deckweiss, (edited )

Tell us what commands you ran exactly and what the terminal responded.

(Do this in general when asking for Linux help btw. that makes it a bit easier to give a useful reply straight away.)

  • All
  • Subscribed
  • Moderated
  • Favorites
  • linux@lemmy.ml
  • DreamBathrooms
  • everett
  • tacticalgear
  • magazineikmin
  • thenastyranch
  • rosin
  • tester
  • Youngstown
  • khanakhh
  • slotface
  • ngwrru68w68
  • kavyap
  • mdbf
  • InstantRegret
  • megavids
  • osvaldo12
  • GTA5RPClips
  • ethstaker
  • normalnudes
  • Durango
  • cisconetworking
  • anitta
  • modclub
  • cubers
  • Leos
  • provamag3
  • JUstTest
  • lostlight
  • All magazines